I was getting an annoying Warning message that stated:

failed to open stream: HTTP request failed! in wp-includes/class-http.php on line 921

I did some research and found this ticket.

I do my development on Ubuntu. I had curl installed, but forgot to add the php5-curl module.

It was an easy fix:

sudo apt-get install php5-curl

sudo service apache2 restart  

Done. Deal.